顺势而为KDJ+MACD+CCI+RSI指标公式

  • 所属栏目: 副图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 副图
  • 公式评级:
  • 公式人气:
  • 公式管理: admin
  • 更新时间: 2016年06月02日
  • 关键字: KDJ,MACD,CCI,RSI,指标,公式
公式源码与图示

RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*400-200; K:SMA(RSV,3,1),COLORYELLOW,NODRAW; D:=SMA(K,3,1); J:3*K-2*D,COLORYELLOW,NODRAW; DRAWBAND(J,RGB(128,0,0),K,RGB(0,0,255)); LC:=REF(CLOSE,1); RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*400-200,COLORMAGENTA,NODRAW; RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*400-200,COLORMAGENTA,NODRAW; DRAWBAND(RSI1,RGB(184,134,11),RSI2,RGB(70,130,180)); DI:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100; DE:=EMA(DI,9); MD:=2*(DI-DE); STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,1.0,0),COLOR0000AB; STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.8,0),COLOR0000BB; STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.6,0),COLOR0000CD; STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0,4),COLOR0000DD; STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.2,0),COLOR0000EC; STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.1,0),COLOR0000FF; STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,1.0,0),COLOR00C3FF; STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.8,0),COLOR00CFFF; STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.6,0),COLOR00D8FF; STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.4,0),COLOR00E2FF; STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.2,0),COLOR00F0FF; STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.1,0),COLOR00FFFF; STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,1.0,0),COLORFF00BB; STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.8,0),COLORFF00D1; STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.6,0),COLORFF00DB; STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.4,0),COLORFF00EA; STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.2,0),COLORFF00F3; STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.1,0),COLORFF00FF; STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,1.0,0),COLORFFA400; STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.8,0),COLORFFB700; STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.6,0),COLORFFC800; STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.4,0),COLORFFDB00; STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.2,0),COLORFFF000; STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.1,0),COLORFFFF00; DIF:(EMA(CLOSE,12)-EMA(CLOSE,26))*100,COLORLIMAGENTA,LINETHICK1; DEA:EMA(DIF,9),COLORLIBLUE,LINETHICK1; MACD:2*(DI-DE),NODRAW; TYP:=(HIGH+LOW+CLOSE)/3; CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORWHITE,LINETHICK2; DRAWICON(CROSS(J,K) AND CROSS(RSI1,RSI2) AND (CROSS(CCI,-100) OR CROSS(CCI,100)),0,9); 200,COLORGREEN,DOTLINE; 150,COLORWHITE,POINTDOT; 100,COLORWHITE,DOTLINE; 0,COLORGRAY,LINETHICK2; -100,COLORWHITE,DOTLINE; -150,COLORWHITE,POINTDOT; -200,COLORGREEN,DOTLINE; DRAWICON(CROSS(J,K),K,1); DRAWICON(CROSS(K,J),K,2); DRAWICON(CROSS(RSI1,RSI2),RSI2,1); DRAWICON(CROSS(RSI2,RSI1),RSI2,2); DRAWICON(CROSS(CCI,-100) OR CROSS(CCI,100),CCI,1); DRAWICON(CROSS(100,CCI),CCI,2); DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,'顺势而为(KDJ+MACD+CCI+RSI)'),COLORYELLOW;


snap.jpg


相邻指标公式
对公式的评论
 以下是对 [顺势而为KDJ+MACD+CCI+RSI指标公式] 的评论,总共:0条评论
热门公式排行