周线DMI指标副图股票公式 0

  • 所属栏目: 副图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 副图
  • 公式评级:
  • 公式人气:
  • 公式管理: admin
  • 更新时间: 2016年04月13日
  • 关键字: DMI,指标,副图,股票,公式
公式源码与图示




P:=14;
M:=6;
AA:= SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),P);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),P);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),P);
PDI:= DMP*100/AA;
MDI:= DMM*100/AA;
ADX:= MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=(ADX+REF(ADX,M))/2;
WMA5:MA(PDI,6);
WMA10:MA(MDI,5);
WMA20:MA(ADX,5);
WMA30:MA(ADXR,5);

梅花1:(WMA5>=WMA10 AND WMA20>=WMA30 AND ( WMA20-WMA30<1.35 OR WMA5-WMA20<1.35) AND WMA5-WMA10<3.8 AND C>REF(C,1)*1.002 AND WMA10<REF(WMA10,1) AND WMA5<30 AND MAX(WMA20,WMA30)<35)*15,COLORFF00FF,LINETHICK3;
梅花2:(WMA5>=WMA10 AND WMA20>=WMA10 AND ( WMA20-WMA10<1.35 OR WMA5-WMA20<1.35) AND WMA5-WMA10<2.8 AND C>REF(C,1)*1.003 AND MAX(WMA20,WMA30)<30)*15,COLOR00FFFF,LINETHICK2;
梅花3:(WMA5>WMA10*1.01 AND (WMA20>=WMA30 OR WMA5>=WMA30 ) AND ( WMA20-WMA10<3.35 OR WMA5-WMA20<5.35) AND WMA5-WMA10<5.8 AND C>O AND WMA5-WMA30<6.55 AND C>REF(C,1)*1.004 AND MAX(WMA20,WMA30)<25)*15,COLOR0000FF,LINETHICK1;

AA2:(CROSS(WMA5,WMA10) AND (WMA10-WMA20<2.55 OR WMA20-WMA10<2.5))*5,COLOR0000FF,LINETHICK3;

--------------------------------------------------------------




P:=14;
M:=6;
AA:= SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),P);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),P);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),P);
PDI:= DMP*100/AA;
MDI:= DMM*100/AA;
ADX:= MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=(ADX+REF(ADX,M))/2;
WMA5:MA(PDI,6);
WMA10:MA(MDI,5);
WMA20:MA(ADX,5);
WMA30:MA(ADXR,5);
YB:=WMA5>WMA10 AND WMA20-WMA30<0.35 AND MAX(WMA20,WMA30)<40;
XG:=YB AND REF(YB<1,1);
方远:(EVERY(WMA5<MIN(MIN(WMA10,WMA20),WMA30) AND WMA5<=REF(LLV(WMA5,6),1)*1.008 AND REF(LLV(WMA5,6),1)<25 AND WMA20<60 AND WMA10-WMA5<30 AND WMA20>=WMA10*0.997,3))*10,COLOR00FFFF,LINETHICK3;

金叉:=(CROSS(WMA5,REF(LLV(WMA5,6),1)) AND WMA20<60 AND REF(LLV(WMA5,6),1)<25)*10,COLORRED;

远方:(EVERY(WMA5<MIN(MIN(WMA10,WMA20),WMA30) AND WMA20<60 AND WMA5>=REF(WMA5,1) AND REF(WMA5,1)<REF(WMA5,3) AND REF(WMA5,2)<REF(WMA5,4) AND REF(LLV(WMA5,5),1)<35 AND C>REF(C,1),2))*10,COLOR0000FF,LINETHICK2;






相邻指标公式
对公式的评论
 以下是对 [周线DMI指标副图股票公式] 的评论,总共:0条评论
热门公式排行