金蝴蝶选股公式源码

  • 所属栏目: 选股公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 选股
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年10月17日
  • 关键字: 通达信,选股,公式,源码
公式源码与图示

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,30);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
M:=EMA(CLOSE,5);
S:=EMA(M,34);
Y:=HHV(MA(HIGH,3),2);
D:=LLV(MA(HIGH,3),1);
QA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
QB:=EMA(0.667*REF(QA,1)+0.333*QA,5);
QC:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1))*100;
Q1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
Q2:=REF(Q1,1);
Q3:=(SMA(MAX(Q1-Q2,0),10,1))/(SMA(ABS(Q1-Q2),10,1))*100;
Q4:=FILTER(IF((COUNT(Q3<20,5))>=1 AND (COUNT(Q1=LLV(Q1,10),10))>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
Q5:=FILTER(S>REF(S,1) AND Y<REF(Y,1) AND CLOSE>REF(CLOSE,1),11);
Q6:=REF(CLOSE,1);
Q7:=(SMA(MAX(CLOSE-Q6,0),6,1))/(SMA(ABS(CLOSE-Q6),6,1))*100;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,55),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
启动:=IF(XL3,0,VAR8*3);
BYPXXG:=启动>10&&(XLPL.NOTEXT吸<1 AND REF(XLPL.NOTEXT落,0.5));
XG:IF(BYPXXG=DRAWNULL,0,BYPXXG);

相邻指标公式
对公式的评论
 以下是对 [金蝴蝶选股公式源码] 的评论,总共:0条评论
热门公式排行