五步曲选股公式源码

  • 所属栏目: 选股公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 选股
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年10月17日
  • 关键字: 通达信,选股,公式,源码
公式源码与图示

N:=9.78;
N2:=1.58;
N3:=1.88;
N4:=26.12;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
VAR1:=EMA(EMA(CLOSE,9),9);
VAR2:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
VAR3:=IF(VAR2>REF(VAR2,1) AND VAR2>0,VAR2,0);
主力持仓:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);

指数趋势:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);

主力筹码集中度:=WINNER(C)*100;
AA:=J>D AND DIF>DEA AND VAR3>0 AND 主力筹码集中度>主力持仓;
个股MSD:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
大盘MSD:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
MSD对比:=(个股MSD-大盘MSD);
BB:=MSD对比>N;
C1:=MA(V,20)/MA(V,200);
CC:=C1>N2;
D1:=ATAN((MA(C,30)/REF(MA(C,30),1)-1)*100)*57.3;
D3:=(MA(D1,13)/10)-((MA(D1,13)/10)*2);
D4:=D3>N3;
D2:=ATAN((MA(C,30)/REF(MA(C,30),1)-1)*100)*57.3;
D3A:=MA(D2,13)/10;
D5:=D3A>N3;
DD:=D4 OR D5;
M:=4;成交:=VOL;VAR4:=成交/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,VAR4*(HIGH-LOW),IF(CLOSE<OPEN,VAR4*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2))*1.5;
主卖:=IF(CLOSE>OPEN,0-VAR4*((HIGH-CLOSE)+(OPEN-LOW)), IF(CLOSE<OPEN,0-VAR4*(HIGH-LOW),0-VOL/2))*1.5;
AA3:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA3*(HIGH-LOW),IF(CLOSE<OPEN,AA3*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖量:=IF(CLOSE>OPEN,0-AA3*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA3*(HIGH-LOW),0-VOL/2));
进出量:=买量+卖量;净流入:=SUM(进出量,M)/100000;市值:=FINANCE(7)*C/100000000;
X4:=净流入/(市值/100);
EE:=X4>N4;
XG:AA AND BB AND CC AND DD AND EE;

相邻指标公式
对公式的评论
 以下是对 [五步曲选股公式源码] 的评论,总共:0条评论
热门公式排行