阴阳主图指标源码

  • 所属栏目: 主图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 主图
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年04月05日
  • 关键字: 主图,源码
公式源码与图示

B:=FORCAST(C,21);

阴阳线:EMA(B,3),linethick1;
Var10:=(3*CLOSE+LOW+OPEN+HIGH)/6;
天:(20*Var10+19*REF(Var10,1)+18*REF(Var10,2)+17*REF(Var10,3)+16*REF(Var10,4)+15*REF(Var10,5)+14*REF(Var10,6)+13*REF(Var10,7)+12*REF(Var10,8)+11*REF(Var10,9)+10*REF(Var10,10)+9*REF(Var10,11)+8*REF(Var10,12)+7*REF(Var10,13)+6*REF(Var10,14)+5*REF(Var10,15)+4*REF(Var10,16)+3*REF(Var10,17)+2*REF(Var10,18)+REF(Var10,20))/210,colormagenta,linethick1;
地:MA(天,12),colorred,linethick1;
合:EMA(天,5),linethick1;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);

Y:=EMA(CLOSE,10);

LL:=REF(CLOSE,2);

MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);

DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);

DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲'),colorred;
DRAWTEXT(CROSS(X,Y),(HIGH * 1.015),'◆'),colorFF6699;
DRAWTEXT(DB,(HIGH * 1.015),'○'),colorFFCC99;
VAR1:=LLV(LOW,21);

VAR2:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);

VAR3:=LLV(LOW,55);

VAR4:=HHV(HIGH,34);

VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);

VAR6:=((AK + VAR5) / 2);

VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);

VAR8:=EMA(VAR6,5);

BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);

AB:=CROSS(AK1,AK);

BB1:=(CROSS(AK1,BB) AND (BB < 30));

CD:=(BB1 * 0.6);

DRAWTEXT((CD = 0.6),(LOW * 0.99),'□'),LINETHICK5,colorFFFFFF;
DRAWTEXT((AB = 1),(LOW * 0.99),'■'),LINETHICK5,color33CC99;
买线:=EMA(C,2);

卖线:=EMA(SLOPE(C,21)*20+C,42);

BU:=CROSS(买线,卖线);

SEL:=CROSS(卖线,买线);

DRAWTEXT(bu,LOW*0.98,'B'),ALIGN1,VALIGN0,colormagenta;
DRAWTEXT(bu,LOW,' ̄'),ALIGN1,VALIGN0,Color208FFF;
DRAWTEXT(sel,HIGH*1.02,'S'),ALIGN1,VALIGN2,colorgreen;


阴阳主图源码

Tags:主图 源码
相邻指标公式
对公式的评论
 以下是对 [阴阳主图指标源码] 的评论,总共:0条评论
热门公式排行