变色源码分析主图公式

  • 所属栏目: 主图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 主图
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年05月04日
  • 关键字: 通达信,K线,涨跌,源码,分析,主图
公式源码与图示

公式源码:仅在日线上变色,分钟线及周线以上均无变色;且通用个股/ST股。涨停颜色选取自通达信高亮文字色。

多细节处理本人原创,以下是源码;


NE:=IF(NAMELIKE('S') OR NAMELIKE('*S'),0.05,0.1);
涨停:=C/REF(C,1)-1>=NE-0.01/REF(C,1) AND C=H AND PERIOD=5;
STICKLINE(涨停,C,O,-1,0),COLORFF00F5;
跌停:=REF(C,1)/C-1>=NE-0.01/REF(C,1) AND L=C AND PERIOD=5;
STICKLINE(跌停,C,O,-1,0),COLOR00FF00;

曾涨停:=H/REF(C,1)-1>=NE-0.01/REF(C,1) AND C<H AND PERIOD=5;
STICKLINE(曾涨停,H-(H-MAX(O,C)),H,0,0),COLORFF00B5;
曾跌停:=REF(C,1)/L-1>=NE-0.01/REF(C,1) AND L<C AND PERIOD=5;
STICKLINE(曾跌停,L+(MIN(O,C)-L),L,0,0),COLOR00BB00;

涨停开盘:=O/REF(C,1)-1>=NE-0.01/REF(C,1) AND O=H AND PERIOD=5;
STICKLINE(涨停开盘,C+(O-C)*0.9,O,-1,0),COLORFF00F5;
跌停开盘:=REF(C,1)/O-1>=NE-0.01/REF(C,1) AND L=O AND PERIOD=5;
STICKLINE(跌停开盘,C-(C-O)*0.9,O,-1,0),COLOR00FF00;

通达信超神看盘让你意外的多细节处理K线涨跌停变色源码分析主图

相邻指标公式
对公式的评论
 以下是对 [变色源码分析主图公式] 的评论,总共:0条评论
热门公式排行