突破回踩主图公式

  • 所属栏目: 主图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 主图
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年09月15日
  • 关键字: 通达信,突破,主图,公式,源码
公式源码与图示

V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1:=MEMA(CLOSE,5);
MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
MA3:=IF(MA2 > 0,MA2,MA2);
VAR1:=CLOSE=HHV(C,4) AND (REF(C,1) >=REF(C,2) OR REF(C,1) >=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE >=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C >=REF(C,1) OR REF(C,3)=HHV (C,4) AND C >=REF(C,1) AND C >=REF(C,2);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=CLOSE=LLV(C,4) AND (REF(C,1) < REF(C,2) OR REF(C,1) < REF(C,3)) OR REF(C,1)=LLV(C,4) AND C < REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C < REF(C,1) OR REF(C,3)=LLV(C,4) AND C < REF(C,1) AND C < REF(C,2);
VAR4:=REF(C,1)=LLV(C,4) AND C >=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1) <=REF(C,3) AND REF(C,2) < REF(C,4) AND C >=REF(C,1);
VAR5:=REF(C,1)=HHV(C,4) AND C < REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1) > REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1) > REF(C,2)) AND REF(C,2) >=REF(C,4) AND C < REF(C,1);
VAR6:=V5 > REF(V5,1) AND REF(V5,1) < REF(V5,2);
VAR7:=LOW < HHV(V5,13) AND HIGH > HHV(V5,13) AND CLOSE > REF(C,1) AND CLOSE > OPEN;
VAR8:=VAR7 AND COUNT(VAR6,2);
VAR9:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR9,2)=LLV(VAR9,7) AND COUNT(VAR9 < 0,2) AND CROSS(VAR9,MA(VAR9,2)))=1,5);
VAR12:=FILTER((HHV(VAR9,2)=HHV(VAR9,7) AND COUNT(VAR9 > 50,2) AND CROSS(MA(VAR9,2),VAR9))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18) >=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR8 AND NOT(REF(VAR8,1));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR4;
买3:=(VAR14 OR VAR15) AND VAR2;
买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);
买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);
TYP:=(HIGH+LOW+CLOSE)/3;
NCC1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
NC1:=SMA(NCC1,3,1);
NC2:=SMA(NC1,3,1);
NC3:=3*NC1-2*NC2;
CB1:=EMA(NC3,5);
CB2:=REF(CB1,1);
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI:=(RSI1-50)*5,LINETHICK2,COLORYELLOW;
NR1:=SMA(RSI,3,1);
ND1:=SMA(NR1,3,1);
NJ1:=3*NR1-2*ND1;
RR1:=EMA(NJ1,5);
RR2:=REF(RR1,1);
RR:=RR1 > RR2;
RSVQ:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
NK:=SMA(RSVQ,3,1);
NK1:=(NK-50)*5,COLORRED;
NK2:=SMA(NK1,3,1);
ND2:=SMA(NK2,3,1);
NJ2:=3*NK2-2*ND2;
NBB1:=EMA(NJ2,5);
NBB2:=REF(NBB1,1);
买N入:=RR AND NOT(REF(RR,1)) AND (NBB1 < -100 AND NBB1 < -100) AND CB1 < -100;
卖N出:=REF(RR,1)=1 AND NOT(RR) AND CB1 > 100,LINETHICK0;
RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K11:=SMA(RSV1,5,1);
D11:=SMA(K11,5,1);
J11:=3*K11-2*D11;
AA11:=EMA(J11,5);
AA22:=REF(AA11,1);
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K22:=SMA(RSV2,3,1);
D22:=SMA(K22,3,1);
J22:=3*K22-2*D22;
BB11:=EMA(J22,5);
BB22:=REF(BB11,1);
DD:=AA11 > AA22 AND BB11 > BB22;
注意买入:=DD AND NOT(REF(DD,1)) AND (AA11 < 50 OR BB11 < 50);
注意卖出:=REF(DD,1)=1 AND NOT(DD);
持仓:IF(CLOSE >=SAR(4,2,20),SAR(4,2,20), DRAWNULL),CIRCLEDOT,COLORRED,;
空仓:IF(CLOSE <=SAR(4,2,20),SAR(4,2,20), DRAWNULL),CIRCLEDOT,COLORGREEN,;
STICKLINE(CLOSE > REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
STICKLINE(CLOSE < REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
STICKLINE(OPEN >=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN >=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN >=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN >=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
STICKLINE(CLOSE > OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE > OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE > OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(CLOSE > OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;
STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000099;
DRAWICON(VAR16,LOW-0.02,7);
DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);
DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);
下降压力线:DRAWLINE(HIGH >=HHV(HIGH,10),HIGH,LOW <=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2;
DRAWICON(买N入,L-0.010,5);
DRAWICON(卖N出,H+0.01,6);
DRAWICON(注意买入,L-0.010,9);
DRAWICON(注意卖出,H+0.010,10);
STICKLINE(CURRBARSCOUNT=2,L,L,10,0),COLORGREEN,;
DRAWNUMBER(ISLASTBAR,REF(L,1),REF(L,1));
;
{买牛股公式网www.MaiNiuGu.com}

相邻指标公式
对公式的评论
 以下是对 [突破回踩主图公式] 的评论,总共:0条评论
热门公式排行