扇形主图公式源码

  • 所属栏目: 主图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 主图
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年09月15日
  • 关键字: 通达信,主图,公式,源码
公式源码与图示

N:=30;
TS:=BARSLAST(L=LLV(L,N));
开始信号:=FILTERX(TS=0,BARSSINCE(C));
开始天数:=BARSLAST(开始信号);
天数横线:=CONST(开始天数);
C2:=REF(C,1);
差:=(高点-低点)/天数横线;
收盘差:=CONST(C)-低点;
对角差:=高点-低点;
差60度:=(高点-低点)*60/对角角度;
差45度:=(高点-低点)*45/对角角度;
差55度:=(高点-低点)*55/对角角度;
差50度:=(高点-低点)*50/对角角度;
差65度:=(高点-低点)*65/对角角度;
角度65:=IF(TS >=0 AND 低点+(差65度/天数横线)*TS <=高点,低点+(差65度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
收盘线:=IF(TS >=0 AND 低点+(收盘差/天数横线)*TS <=高点,低点+(收盘差/天数横线)*TS,DRAWNULL);
低点: DRAWLINE(L=LLV(L,N),L,ISLASTBAR,REF(L,TS),1),COLOR00CC00;
高点: DRAWLINE(L=LLV(L,N),CONST(HHV(H,天数横线)),ISLASTBAR,REF(CONST(HHV(H,天数横线)), TS),1),COLOR00CCCC;
STICKLINE(开始信号,L,CONST(HHV(H,天数横线)),0,0),COLOR00AA00;
STICKLINE(ISLASTBAR,低点,高点,0,0),COLOR00AA00;
对角角度:ATAN((对角差/(对角差*((天数横线-1)/天数横线))-1)*100)*57.3,COLORFFFF00,NODRAW;
角度50:IF(TS >=0 AND 低点+(差50度/天数横线)*TS <=高点,低点+(差50度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度55:IF(TS >=0 AND 低点+(差55度/天数横线)*TS <=高点,低点+(差55度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
对角线:IF(TS >=0 AND 低点+差*TS <=高点,低点+差*TS,DRAWNULL),COLORYELLOW,LINETHICK2;
角度60:IF(TS >=0 AND 低点+(差60度/天数横线)*TS <=高点,低点+(差60度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度45:IF(TS >=0 AND 低点+(差45度/天数横线)*TS <=高点,低点+(差45度/天数横线)*TS,DRAWNULL),COLORGREEN;
收盘角度: (收盘差*对角角度)/对角差,NODRAW;
;
{买牛股公式网www.MaiNiuGu.com}

相邻指标公式
对公式的评论
 以下是对 [扇形主图公式源码] 的评论,总共:0条评论
热门公式排行