均线K线主图指标公式

  • 所属栏目: 主图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 主图
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年09月17日
  • 关键字: 均线,K线,主图,指标,源码,通达信
公式源码与图示

VAR1:=CLOSE > REF(CLOSE,1) AND CLOSE > REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VARD:=CLOSE < REF(CLOSE,1) AND CLOSE < REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE <=REF(CLOSE,1) AND CLOSE >=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE >=REF(CLOSE,1) AND CLOSE <=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 ORVAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
X:=(3*C+L+O+H)/6;
DD:=多空线 < REF(多空线,1);
A:=(PMA > 多空线);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 ORVAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 ORVAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORFFCC66;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,1),COLORYELLOW;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),5,2),COLOR00FF00;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00C8FF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ECFF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10FFFF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORBLUE;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;
PMA:MA(C,5),COLORWHITE,LINETHICK2;
IF(PMA > REF(PMA,1),PMA,DRAWNULL),COLORRED,LINETHICK2;
IF(PMA < REF(PMA,1),PMA,DRAWNULL),COLORGREEN,LINETHICK2;
多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+REF(X,20))/210,COLORFF00FF,LINETHICK2;
IF(DD,多空线,DRAWNULL),COLOR00FFFF,LINETHICK2;
IF(A,多空线,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;
{买牛股公式网www.MaiNiuGu.com}

均线K线主图指标源码通达信

相邻指标公式
对公式的评论
 以下是对 [均线K线主图指标公式] 的评论,总共:0条评论
热门公式排行