涨跌台阶主图指标公式

  • 所属栏目: 主图公式
  • 公式平台: 通达信/同花顺/大智慧
  • 授权方式: 免费源码
  • 适用类别: 主图
  • 公式评级:
  • 公式人气:
  • 公式管理: Admin
  • 更新时间: 2018年10月17日
  • 关键字: 涨跌,主图,指标,源码,通达信
公式源码与图示

SW:=1;CL:=10;
CON1:=IF(SW=1,IF(L=LLV(L,8*CL),L,DRAWNULL),IF(H=HHV(H,8*CL),H,DRAWNULL));

CON2:=IF(SW=1,CONST(BARSLAST(CON1=L))+1,CONST(BARSLAST(CON1=H))+1);

BLIN:IF(CURRBARSCOUNT<=CON2,CONST(IF(SW=1,IF(CON2=1,L,REF(L,CON2-1)),IF(CON2=1,H,REF(H,CON2-1)))),DRAWNULL);

ST0.5:IF(SW=1,BLIN*1.0809,BLIN/1.0809),COLOR89615F;
ST1:IF(SW=1,BLIN*1.1618,BLIN/1.1618),COLOR89615F;
ST1.5:IF(SW=1,IF(CONST(EXIST(C>ST1,CON2)),ST1*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST1,CON2)),ST1/1.0809,DRAWNULL)),COLOR89615F;
ST2:IF(SW=1,IF(CONST(EXIST(C>ST1.5,CON2)),ST1*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST1.5,CON2)),ST1/1.1618,DRAWNULL)),COLOR89615F;
ST2.5:IF(SW=1,IF(CONST(EXIST(C>ST2,CON2)),ST2*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST2,CON2)),ST2/1.0809,DRAWNULL)),COLOR89615F;
ST3:IF(SW=1,IF(CONST(EXIST(C>ST2.5,CON2)),ST2*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST2.5,CON2)),ST2/1.1618,DRAWNULL)),COLOR89615F;
ST3.5:IF(SW=1,IF(CONST(EXIST(C>ST3,CON2)),ST3*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST3,CON2)),ST3/1.0809,DRAWNULL)),COLOR89615F;
ST4:IF(SW=1,IF(CONST(EXIST(C>ST3.5,CON2)),ST3*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST3.5,CON2)),ST3/1.1618,DRAWNULL)),COLOR89615F;
ST4.5:IF(SW=1,IF(CONST(EXIST(C>ST4,CON2)),ST4*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST4,CON2)),ST4/1.0809,DRAWNULL)),COLOR89615F;
ST5:IF(SW=1,IF(CONST(EXIST(C>ST4.5,CON2)),ST4*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST4.5,CON2)),ST4/1.1618,DRAWNULL)),COLOR89615F;
ST5.5:IF(SW=1,IF(CONST(EXIST(C>ST5,CON2)),ST5*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST5,CON2)),ST5/1.0809,DRAWNULL)),COLOR89615F;
ST6:IF(SW=1,IF(CONST(EXIST(C>ST5.5,CON2)),ST5*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST5.5,CON2)),ST5/1.1618,DRAWNULL)),COLOR89615F;
ST6.5:IF(SW=1,IF(CONST(EXIST(C>ST6,CON2)),ST6*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST6,CON2)),ST6/1.0809,DRAWNULL)),COLOR89615F;
ST7:IF(SW=1,IF(CONST(EXIST(C>ST6.5,CON2)),ST6*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST6.5,CON2)),ST6/1.1618,DRAWNULL)),COLOR89615F;
ST7.5:IF(SW=1,IF(CONST(EXIST(C>ST7,CON2)),ST7*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST7,CON2)),ST7/1.0809,DRAWNULL)),COLOR89615F;
ST8:IF(SW=1,IF(CONST(EXIST(C>ST7.5,CON2)),ST7*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST7.5,CON2)),ST7/1.1618,DRAWNULL)),COLOR89615F;
ST8.5:IF(SW=1,IF(CONST(EXIST(C>ST8,CON2)),ST8*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST8,CON2)),ST8/1.0809,DRAWNULL)),COLOR89615F;
ST9:IF(SW=1,IF(CONST(EXIST(C>ST8.5,CON2)),ST8*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST8.5,CON2)),ST8/1.1618,DRAWNULL)),COLOR89615F;
ST9.5:IF(SW=1,IF(CONST(EXIST(C>ST9,CON2)),ST9*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST9,CON2)),ST9/1.0809,DRAWNULL)),COLOR89615F;
ST10:IF(SW=1,IF(CONST(EXIST(C>ST9.5,CON2)),ST9*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST9.5,CON2)),ST9/1.1618,DRAWNULL)),COLOR89615F;
ST10.5:IF(SW=1,IF(CONST(EXIST(C>ST10,CON2)),ST10*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST10,CON2)),ST10/1.0809,DRAWNULL)),COLOR89615F;
ST11:IF(SW=1,IF(CONST(EXIST(C>ST10.5,CON2)),ST10*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST10.5,CON2)),ST10/1.1618,DRAWNULL)),COLOR89615F;
ST11.5:IF(SW=1,IF(CONST(EXIST(C>ST11,CON2)),ST11*1.0809,DRAWNULL),IF(CONST(EXIST(C<ST11,CON2)),ST11/1.0809,DRAWNULL)),COLOR89615F;
ST12:IF(SW=1,IF(CONST(EXIST(C>ST11.5,CON2)),ST11*1.1618,DRAWNULL),IF(CONST(EXIST(C<ST11.5,CON2)),ST11/1.1618,DRAWNULL)),COLOR89615F;


涨跌台阶主图指标源码通达信

相邻指标公式
对公式的评论
 以下是对 [涨跌台阶主图指标公式] 的评论,总共:0条评论
热门公式排行